Cry of Fear - Forum

Modding => Modding Help => Topic started by: DivGreener a.k.a. Hex on 03 November, 2014, 01:00:39 AM

Title: Env_models and brush entities are not visible
Post by: DivGreener a.k.a. Hex on 03 November, 2014, 01:00:39 AM
First, I just want to say that I am beginner in Cry of Fear "development" world and my English is not really advanced... Just sayin'  :joebiden:

I am trying to make cry of fear custom campaign, but unfortunetly, it does not let me to even finish my first forest map.
I made a cutscene and first section of the map (trees, wawood textures, buskes, and things like this), just models and grass and everything is covered with SKY textures. Everything was great. Models and everything, perfect. But then I made something like hallway out of SKIES and behind it there is large area with heck lot of models. I compiled the map and played it in engine. Everything was good except of the large area. About 1/4 of the models (mainly skogsris.mdl and smoaspar.mdl) were visible, and something like 3/4 were not! (trees, buskes, aspars, grans, this wood wall you can see on third image, and stuff)
I thought this is because of this area, too big maybe, so I tried to make it smaller. Same thing. I've read something about HINT brushes. I placed them into the map and buskes showed up! But only them. Also, I know now, there is a limit in models (255), so I removed a bunch of them, but func_walls were gone. I don't know where is the problem living, in vis, or rad (or, maybe even csg or bsp, but it seams that there is no problem with level geometry).

So things I've tried:
 - resizing the area,
 - placing some HINTs,
 - moving some entities closer to see if then they will show up,
 - grouping them (yeah, dumb idea, but I thought it might work,  :stig:
 - replacing entities with new ones
 - bringing down ceiling (SKY).

My questions:
 - why is that happening?
 - is there any way to fix it?
First section (
"Hallway" (
Large area (
Construction site (

WAD file:

If anyone can help me, then please answer it, because I can't find anything on this forum  :(