Author Topic: Custom Key Inventory Images Error  (Read 4701 times)

levit123

  • Donator
  • Member
  • *
  • Posts: 72
  • I'm the leader, mapper, and animator of Alone.
    • View Profile
    • Alone - Cry of Fear Mod
Custom Key Inventory Images Error
« on: 13 July, 2015, 07:55:48 AM »
So, following this guide http://www.cry-of-fear.com/forum/index.php?topic=4721.0, I was able to create a key for a door in a map that I am currently working on. The key works, and I can tell that the directories are correct (both in the item_key entity and in the actual folders for Cry of Fear), but, in the inventory slots, the image that I used for the key has a completely white background, instead of a transparent background.

I am using paint.net with a plug-in that allows me to open and work with .PSD files. After opening and working with "slot ref.psd" and "check ref.psd", I saved them as new .TGA's, using "auto" on the compression/bit part, and choosing to flatten them.

Again, the key appears in the inventory, it just has a white background in the slot.

Is there something I'm doing wrong? Do I have to save it as something like 16 bit, or something?

Any help would be greatly appreciated.
Are you surprised when sentences don't end as you potato?

CanYouNot

  • Donator
  • Member
  • *
  • Posts: 43
  • I question a lot of things.
    • View Profile
    • Insomnia
Re: Custom Key Inventory Images Error
« Reply #1 on: 13 July, 2015, 03:34:42 PM »
I'm using Paint.NET too and know how to fix this.
I was at the same dilemma as you are at a few days ago trying to do the same thing for a custom key and a custom subway map and note.
In the end I found out that you have to save the images as "32-Bit uncompressed .TGAs with Transparent backgrounds."

Hope that helps.  :)
I'm pretty adept at what I do.
My only drawback is my lack of focus.

levit123

  • Donator
  • Member
  • *
  • Posts: 72
  • I'm the leader, mapper, and animator of Alone.
    • View Profile
    • Alone - Cry of Fear Mod
Re: Custom Key Inventory Images Error
« Reply #2 on: 14 July, 2015, 03:41:17 AM »
"32-Bit uncompressed .TGAs with Transparent backgrounds."

It totally worked! Thanks! Could we get a mod to sticky this, so that it might help someone else out?

EDIT: One last thing; does this apply to custom notes as well? When I copied an existing note TGA and modified it, it doesn't show up when I boot up the map. I go to where the note is placed, and interact with it, and when it opens up the rusty red background, the note doesn't show up.
« Last Edit: 14 July, 2015, 04:23:56 AM by levit123 »
Are you surprised when sentences don't end as you potato?

CanYouNot

  • Donator
  • Member
  • *
  • Posts: 43
  • I question a lot of things.
    • View Profile
    • Insomnia
Re: Custom Key Inventory Images Error
« Reply #3 on: 14 July, 2015, 05:27:51 AM »
Yes it does. All .TGA files have to be uncompressed.  :) Or else weird stuff happens   :stig:
I'm pretty adept at what I do.
My only drawback is my lack of focus.